User Tools


Table of Contents

Chapter 2. The GUI

Version 2.1, © 2019, 2020 Energy Simulation Solutions Ltd



The main user interface of jEPlus is shown in Figure 2.1. Most of the controls are located on the Project Params/Result Collection/Execution/Utilities tabs on the left side of the window, as well as on the menu. On the right are the panels for the program's outputs and logs, and the file editors etc.

Figure 2.1: jEPlus v2.1 GUI

2.1 What's on the menu

Figure 2.2 shows what’s on the menu bar. In the ‘File’ menu, there are the usual ‘New/Open/Save’ commands. The jEPlus v2.x project files are saved in JSON format with the extension ‘.json’ by default. JSON is a concise text-based data format that is quite easy to read and modify with a text editor or a dedicated JSON editor.

You can open existing jEPlus v1.X project files (.jep) in jEPlus v2.x. When you save the project, it must be saved in the new format. The older jEPlus v0.5 project files (.obj) are no longer supported.

In the 'Edit' menu, you can convert all file paths referenced in the project to the relative or the absolute form. If you want to run the project using the JESS online simulation service, having all project files within one folder and using only the relative paths is essential. Please also note that jEPlus does not support 'Undo' of any actions performed by the user.

The most useful commands in the ‘Action’ menu are opening the output folder and the jEPlus result files of the project. You can also create the full list of “jobs” containing all the permutations defined in the project.

In the ‘Tools’ menu, you can access the 'Configure External Programs' dialogue and open the jEPlus error log file, along with some other functions.

The 'Help' menu contains the information of this program and the link to this online user's guide.

Figure 2.2: jEPlus menu structure

2.2 The 'Project Params' tab

jEPlus can help you manage complex parametric simulations. You will still need to plan a parametrics project carefully and do some preparations, e.g. testing the building model, choosing the parameters and the value range for each parameter, and, ultimately, deciding how to process the results. The 'Project Params' tab on the GUI is where you define the parametric project (Chapter 3) and the parameters (Chapter 4). It is the place where you designate input files and create the parameters. You can also use the 'Validate project' command to count jobs and check potential errors (see Figure 2.4 below).

Figure 2.3: The Project Tab
Figure 2.4: Validation result

jEPlus supports also TRNSYS parametric projects and run simulations in parallel. The mechanism is more or less the same as with EnergyPlus, except that the output file names are user-defined in TRNSYS. As a result, you will need to specify which output file(s) jEPlus should collect after running the simulations. Please bear in mind that jEPlus can only collect files in CSV format, with the first row containing column names. Below is how the 'Project Params' tab looks with a TRNSYS project:

Figure 2.5: Project tab for TRNSYS

2.3 The 'Result Collection' tab

The 'Result Collection' tab is a new addition in jEPlus v2.0. It lets you define the result collection tasks and calculate user-defined metrics. For EnergyPlus, you can extract simulation results from the ESO output (using RVI/MVI), the SQL output, the tabular reports in eplustbl.csv, as well as taking values a user-supplied list associated with the case IDs. You can also call Python scripts within the result collection process.

For TRNSYS users, the TRN objects define what report variables to take from the simulation results. You can also use Python for post-processing.

Figure 2.6: The Result Collection Tab

2.4 The 'Execution' tab

The Execution tab does two things, letting you choose which jobs of the project to run, and how (and where) to run them.

Figure 2.7: The Execution Tab

2.5 The ‘Utilities’ tab

Three utilities are included in the jEPlus GUI. They are a Python script tester, an IDF version converter shell, and a ReadVarsESO caller. The details of these utils are provided in Chapter 7.

Figure 2.8: The Utilities Tab

2.6 The IDF Editor

Simple text editors are included in jEPlus for editing the model templates and other files. The editor can be opened by pressing the [Edit] button next to the referenced file box. Within the editor, apart from the open and save buttons, two search facilities are provided for locating the existing search strings as well as arbitrary text. Regular expression search is also supported.

Figure 2.9: IDF editor


2.7 The Configure External Programs Dialog

Another new addition to jEPlus v2.1 is the Configure External Programs Dialog. Here you can assign EnergyPlus (multiple versions can be selected), TRNSYS, the script language platforms, and the E+ IDF updater executables to the program. This information is saved in tools.json file along with a recently used projects list.

The access this dialog, go to the 'Tools' menu.

Figure 2.10: The Configure External Programs Dialog

Site Tools